Verschlüsselungs-Trojanern ein Schnippchen schlagen

Gegen die grassierende Seuche der Verschlüsselungs-Trojaner (“Ransomware”) gibt es nur wenige Gegenmittel – abgesehen von extremer Zurückhaltung beim “Klicken” im Internet und beim Öffnen von Mails (bzw. Attachements) hilft eigentlich nur die alte Weisheit:
“Safe early, safe often”.

Da es diese Schädlinge hauptsächlich auf Dateien abgesehen haben, die dem Benutzer lieb und wert sind (bzw. sein Einkommen sichern) kann man die Daten regelmässig auf ein externes Laufwerk sichern und dieses während des normalen PC-Gebrauchs abstecken (bzw. auschalten). Das vergisst man aber immer wieder einmal – und falls in diesem Moment die “Ransomware” zuschlägt ist auch die Sicherung futsch (bzw. verschlüsselt).
Oder man bedient sich einer NAS-Lösung, auf die man die Daten mittels FTP-Upload sichert – allerdings auch etwas umständlich.

Ich habe mir eine Methode ausgedacht, welche die Daten verschlüsselt sichert, (höchstwahrscheinlich) vor dem Zugriff von Ransomware schützt und gleichzeitig die tägliche Sicherung erleichtert:

Ich habe mir eine zusätzliche, grosse Festplatte eingebaut und darauf eine Partition angelegt, ohne diese zu formatieren (die Partition ist notwendig, da sonst Windows immer wieder darauf hinweist, dass die Platte zu partitionieren & formatieren wäre).

Dann installiert man Truecyrpt oder besser dessen Nachfolger Veracrypt; diese Verschlüsselungs-Software ist in der Lage, auch unformatierte Partitionen als Datencontainer zu benutzen. Somit ist während des normalen Betriebs diese Festplatte nur als unformatiertes Laufwerk vorhanden und für das Betriebssystem und in weiterer Folge für eine fallweise eingeschleppte Ransomware nutzlos – auf nicht formatierten Laufwerken kann man normalerweise nichts speichern und eben auch nichts löschen oder verschlüsseln.
Die gesamte (unformatierte) Partition wird nun mittels Truecrypt oder Veracrpyt komplett als Datencontainer “formatiert” (Schnellformatierung reicht hier völlig aus).
Die Verwendung eines einfachen Passworts reicht hier ebenfalls, da dieses später für zusätzlichen Komfort in der Batch-Datei für die halbautomatische Sicherung gespeichert wird.

Um jetzt komfortabel die Daten regelmässig auf diesen (verschlüsselten) “Datencontainer” zu sichern bedienen wir uns eines weiteren gratis erhältlichen Tools – “ROBOCOPY” aus dem “Windows Server 2003 Resource Kit Tools 1.0”. Diese kleine “App” (wie man heute sagen würde) kopiert man vorzugsweise (mit administrativen Rechten) in das Windows\System32-Verzeichnis, da man von überall darauf zugreifen kann.

Dann legt man sich noch eine kleine, feine Batch-Datei an, mittels der man die (unformatierte, verschlüsselte) Partition als virtuelles Wechsellaufwerk mountet, mit Robocopy alle wichtigen Daten(ordner) auf dieses Laufwerk spiegelt und danach das Laufwerk wieder “aushängt”, also dismounted und somit vor dem Zugriff von Ransomware (und anderen Personen 😉 schützt.

Meine Batch-Datei sieht beispielsweise so aus – die entsprechenden Variablen können in den Manuals zu Truecrypt bzw. Veracrypt nachgelesen werden, für das Herausfinden der Volume- bzw. Partition-ID des neuen Laufwerks gibt es mehrere Methoden, ich habe zum Anlegen der leeren Partiton und zum Auslesen der speziellen ID ganz einfach den “Partition Master” von EASEUS verwendet:

"c:\Program Files\TrueCrypt\TrueCrypt.exe" /ls /q /a /c n /m rm /p PASSWORT /v \\?\Volume{aa75cec5-be3b-73da-25aa-ad79f0efeb7f}\

robocopy C:\ORDNER s:\ORDNER /mir /xd $RECYCLE.BIN "System Volume Information"

"c:\Program Files\TrueCrypt\TrueCrypt.exe" /q /ds

Bei “PASSWORT” ist klarerweise das vorher beim Erstellen des verschlüsselten containers verwendete (einfache) Passwort einzutragen, zwischen die geschwungenen Klammern kommt die ID der (unformatierten) Partition. Alternativ kann man hier zB auch “\Device\Harddisk2\Partition2” angeben, die korrekte Bezeichnung findet man in Truecrypt heraus, indem man auf “Select Device…” klickt.
Die Befehlssyntax von Robocopy ist noch einfacher: Quelle, Ziel und den Parameter “/mir” (für Mirror) angeben – fertig. Mit dem Parameter “/xd” kann man eine Reihe von (Unter-)Ordnern angeben, die NICHT mitgespiegelt werden sollen.

Gesichert wird jetzt (zusätzlich zur “normalen” laufenden Sicherung) zwei mal täglich – somit sollte sich bei einem tatsächlich auftretenden Schädlingsbefall der Schaden in Grenzen halten.

Glück auf und immer wachsam bleiben!

Grosse Dateien mit SMASH gratis versenden…

Heute bin ich im Blog von Gunther Wegner auf einen interessanten neuen Dienst gestoßen, der die einfache Dateiübertragung von beliebig großen Dateien via email und Downloadlink ermöglicht – gratis, ohne Werbung und mit einer Speicherdauer von maximal 7 Tagen. Hier der Link zum Originalartikel:
http://gwegner.de/blog/fromsmash-com-grosse-dateien-uebertragen-leicht-gemacht/

Aber nicht vergessen, sensible Daten vor dem Versand zu verschlüsseln – man weiß ja nie, wer mitliest!

Das PC-Upgrade 2017 – Teil 2

Wie im letzten Artikel beschrieben verlief bei der Erneuerung der Hauptbestandteile meines Arbeitsplatz-Workhorses alles glatt – bis auf die Probleme mit der m.2 SSD von Samsung, die nach einem Warmstart nicht mehr erkannt wurde.

Ich ignorierte das Problem erstmal und lies ein paar Vergleichstests laufen, um mir ein Bild über den zu erwartenden Geschwindigkeitsboost mit der m.2-SSD  zu machen – die technischen Daten lasen sich ja vielversprechendend (…bis zu 3.200MB/s sequentielle Lese und 1.900MB/s Schreibgeschwindigkeit…). Also – schaumamal:

Beginnen wir mit einer relativ schnellen Western Digital-Festplatte mit 4 GB – da sehen die Werte so aus:

Mit einer handelsüblichen, durchschnittlichen SSD von Samsung mit 1 TB um ca. 350 Euro wird die Sache schon etwas flotter – im Vergleich zu den alten SCSI- (oder PATA, Gott behüte!) Zeiten allerdings schon wahnsinnig schnell:

So gesehen ist der Speed einer direkt an den PCI-Express-Bus gehängten m.2-SSD mit 1 TB abnormal – die gute Samsung 960 Evo hält tatsächlich, was sie verspricht:

Kaum zu glauben, dass dieses kleine Kärtchen soviel Dampf machen kann!

Das alles hilft aber natürlich gar nichts, wenn die Platte nach jedem Warmstart nicht mehr im System auftaucht – also ab in die Support-Warteschlange.

Ich schilderte (etwa am 10.1.) das Problem dem Asus Support und erhielt nach relativ kurzer Zeit (2 Tage!) und in weiterer Folge freundliche, obgleich wenig hilfreiche Antworten und Tipps, z.B. einen BIOS-Reset durchzuführen, das Quickboot-Menü zu deaktivieren oder die POST-timeout zu erhöhen. Ich probierte brav alles durch, obwohl es nichts brachte – nur den Rat, auf eine ältere BIOS-Version downzugraden, ignorierte ich:

Bitte setzen Sie einmal das BIOS hardwarenah zurück. Schalten Sie dazu bitte das Netzteil aus und entnehmen Sie die CMOS-Batterie. Setzen Sie diese dann andersherum wieder ein, und warten Sie mindestens fünfzehn  Minuten. Danach setzten Sie die Batterie richtigherum wieder ein und schalten das Netzteil wieder ein. Stellen Sie dann im BIOS die Standardeinstellungen wieder her (Taste F5) und speichern diese ab. Wenn Sie z.B. ein RAID eingerichtet haben, stellen Sie den entsprechenden SATA-Controller bitte wieder auf RAID. Testen Sie dann bitte, ob das von Ihnen beschriebene Verhalten noch auftritt.

Bitte stellen Sie einmal im BIOS die Post delay Time etwas höher. Evtl. benötigt die m.2 beim Reset eine längere Initialisierungszeit durch das neue BIOS. Haben Sie schon einmal ein Downgrade auf eine frühere BIOS Version versucht?

Ich lies die Sache also auf sich beruhen und ärgerte mich in der Zwischenzeit mit meinem neuen 32-Zöller herum – ärgern ist vielleicht etwas übertrieben, aber wenn man sich auf einen neuen Riesenmonitor mit hoher Auflösung (Philips Philips BDM3270QP) freut und dieser in einer beschädigten Verpackung und ohne jegliches Zubehör, ja nicht einmal mit einem Standfuß, geliefert wird, kann einem die Vorfreude schon vergehen. Ich bin aber andererseits froh darüber, denn umgehend zurückgesandt entdeckte ich ebenfalls beim großen Versandhaus den BenQ BL3201PT mit echter UHD-Auflösung (3840 X 2160 Pixel) und – den Rezensionen nach – sehr guter Eignung als CAD- oder Fotobearbeitungsmonitor. Er deckt den den kompletten sRGB-Farbraum ab, also das, was üblicherweise im Internet verbreitet wird – ich maße mir nicht an, bei normalen Fotomotiven den Unterschied zwischen sRGB und AdobeRGB unterscheiden zu können, also reicht das für meine Zwecke vollkommen aus. Der BenQ war einige Tage später schon im Haus und nach kurzer Aufwärmzeit ging´s an´s Auspacken und Aufstellen. Zum Glück ist mein Schreibtisch groß genug – so ein 32-Zöller hat schon ordentliche Ausmaße! Allerdings war natürlich das Anschlußkabel zu kurz, also ein längeres HDMI-Kabel gecheckt, kann losgehen…aha, kein Bild. Neu booten. Windows-Logo, dann kein Bild. Auflösungstechnisch kann´s kein Problem sein, meine Radeon R9-Grafikkarte packt die Pixelanzahl locker. Also ab in´s Bildschirmmenü (ui, der hat sogar eine Kabel-Fernbedienung, die an eine USB-Schnittstelle gesteckt wird!) und ein paar Einstellungen bzw. Eingangsvarianten durchgeklickt – siehe da, ein Bild, in voller Pracht!

Wenn man von 1920 x 1200  auf 3840 X 2160 Pixel umsteigt, glaubt man, man hätte vorher in einen alten portablen Röhrenfernseher geglotzt (auch wenn EIZO draufsteht) – beeindruckend! Beeindruckend allerdings auch, was Windows 10 und sogar die Adobe Creative Suite mit dem überbordenden Pixelangebot machen, denn da gibt es einige Finetunings, mit denen man Stunden verbringen kann. Besonders ärgerlich ist zB, dass diverse Windows-Systemmenüs (IMMER!!!) noch nicht korrekt skaliert werden und dass zB Photoshop und Indesign ihre Einstellungen für die Bildschirmskalierung an unterschiedlicher Stelle anbieten – such, lieber User, such! In Adobe Lightroom habe ich dann wiederum keine Möglichkeit für eine vergrößerte Bildschirmdarstellung gefunden – also doch die Lesebrille aufsetzen.

Ziemlich ärgerlich wird die Sache allerdings wenn man (so wie ich 😉 zusätzlich noch einen zweiten Monitor mit 1920×1200 Pixel an das System dranhängt – dann kommt sich nämlich die Fenster-/Symbolskalierung von Windows gegenseitig in´s Gehege und man hat entweder eine Mini-Fuzzi-Zwergerl-Anzeige am kleineren Monitor oder eine zu große Darstellung am großen Bildschirm…hin und her, wie man´s auch dreht und wendet, es wird nix mit der perfekt im Zweitmonitor dargestellten virtuellen Maschine (ja, mein altes XP lebt auch noch), irgend etwas sieht einfach immer Scheisse aus.

Als ich dann diverse Remote-Desktop-Verbindungen zu unseren Servern ausprobiere kommt mir die erlösende Idee: Warum nicht die alte XP-Maschine in ihrem VMware-Player “versteckt” laufen lassen und via Remote-Desktop am Zweitschirm darstellen – die Performance reicht ja locker aus. Und siehe da, das gute RDP-Programm liefert ein perfekt auf 1920×1200 skaliertes Bild meiner (virtuellen) XP-Maschine, alles ist gut:

Am Tag darauf kommt auch die (scheinbar) erlösende Antwort vom ASUS-Support: Es gibt ein neues Firmware-Update für die m.2 SSD, mit dem das Problem des “Verschwindens” behoben sein soll(te). Allerdings musste ich noch zwei Tage auf das Erscheinen dieses Updates warten – Samsung hatte einmal arge Probleme mit einem vorschnell veröffentlichten Firmware-Update einer Festplatte und liefert seitdem die Updates nur mehr verzögert aus. Wahrscheinlich hoffen sie, dass sich ein paar User prompt melden, sollten die Daten ihrer SSD beim Update den Gang in´s Nirwana angetreten haben. Erschreckende Vorstellung…bei den gängigen Sicherungsgepflogenheiten unbedarfter Anwender!

To be continued a.s.a.p.!

 

Das PC-Upgrade 2017: Zwei kleine Wunder ;-)

Workstation 2017 mit Asus X99-AII und Samsung EVO 960 M.2 SSD mit 1 TB (grünes Rechteck)

Gestern habe ich mein “Arbeitspferd” auf den aktuellen Stand der Technik gebracht – und es geschah ein kleines Wunder:
Alles funktionierte auf Anhieb.

Heute habe ich noch das BIOS des Motherboards auf den aktuellen Stand gebracht – und es geschah wieder ein kleines Wunder:
Seitdem wird die pfeilschnelle und sauteure 1 TB Samsung M.2-SSD nicht mehr erkannt.

Aber wen wundert so etwas schon, wenn er nur ausreichend lange IT-Erfahrung vorweisen kann?

 

Hardware-Aufstellung mit aktuellen Preisen (Stand 12/2016)


  • Samsung MZ-V6E1T0BW SSD 960 Evo NVMe M.2 1 TB: € 439,00
  • INTEL Core i7-6800K 3,40GHz LGA2011-V3 15MB Cache Boxed CPU: € 452,70
  • Asus X99-A II Mainboard (Sockel 2011-v3, ATX, Intel X99, 8x DDR4-Speicher, USB 3.1, M.2 Schnittstelle): € 272,16
  • Kingston 4 x D4 8GB 2400-17 Sx8 KVR: € 207,48
  • THERMALRIGHT Lüfter Therma Macho 120 Rev.A: € 40,89
Macht summa summarum: € 1.412,23

Lightroom CC 2015 – die Update-Katastrophe

…mir ist es am WOE (trotz gültigem Adobe-Cloud-Abo!) trotz zahlreicher Versuche nicht gelungen, Lightroom auf die aktuellste Version upzudaten – die Fehlermeldung war eine kopmlette Fehlanzeige und ich habe ausser Deinstallationsempfehlungen des gesamten Adobe-Pakets auch nichts entsprechendes im Netz gefunden. Der Hit daran: Obwohl das Installationspaket ca. 350 MB besitzt hat das Creative Cloud Abo-Programm nach dem Installationsfehler und Abbruch bei jeder Wiederholung von vorne begonnen, das Paket herunterzuladen…obwohl man quasi beobachten konnte, dass der Fehler erst kurz nach Beginn der tatsächlichen Installation auftritt… (danke, Adobe!)

Leider misslang aber auch die Deinstallation von Lightroom (sowohl via Cloud-Manager als auch Programm-Manager in der Systemsteuerung) sodass ich schon befürchtete, mein System komplett von allen Adobe-Programmen zu befreien zu müssen (händisch – eine Katastrophe!).

Als letzten Ausweg dachte ich mir dann noch – wieso nicht so wie in den guten alten DOS-Zeiten vorgehen: Eventuell kann ich das Update am Notebook durchführen und die Programmdateien dann einfach auf meinen Stand-PC übertragen…obwohl ich dieser Methode wenig Chancen einräumte. Also vorher noch Plattenimage ziehen…Notebook aktualisieren (dort klappte es mit demselben User-Account für die Adobe Cloud problemlos) und dann einfach den Programmordner komplett rüberkopiert.

Starten….warten…funktioniert!

p.s.: Nach den zahllosen Einträgen in diversen Foren bin ich nicht der einzige mit haufenweise Problemen mit dem Cloud-Abo und den dazugehörigen Installationen oder Updates – das Abomodell mag ja vielleicht gut in Hinblick auf Updatehäufigkeit und Geldbörse von Adobe sein, für uns User ist es aber ein einziger “Pain in the Ass”!

Aus NT4 (32bit) wird Server 2016 (64bit)

Was bisher geschah:

  • Virtualisierung der NT4-Maschine (komplett)
  • Erzeugung eines VMware-Clons lokal
  • Deinstallation der VMware-Tools unter NT4 (wichtig!)
  • Upgrade von NT4 auf Server 2000
  • Wichtig: Installation des ServicePacks 4 und Installation des KB835732 (Windows2000-KB835732-x86-DEU.exe), sonst funktionert der folgende Schritt nicht:
  • Installation der VMware-Tools unter Server 2000
  • Installation einer virtuellen XP-Maschine im lokalen (nur VM-Host) Netz des Servers2000 – Zugriffskontrolle, Exchange 5.5 funktioniert nach wie vor
  • Installation eines Servers 2008R2 inkl. Servicepacks (wiederum im lokalen Host-Netz), Integration des Servers in die Domäne des Servers 2000
    Wichtig: Server 2000 muss als DNS-Server fungieren und sich selbst als DNS-Server verwenden – die Domainserver- und Domain-Einträge im DNS müssen vorhanden sein. Server 2008 muss den Server 2000 als DNS-Server verwenden.
  • Am Server 2000 (!) von der Server 2008-CD aus dem Ordner “Support\Adprep”  den Befehl adprep32 /forestprep durchführen
  • Die Domäne am Server 2000 unter “Active Directory-Domänen und Vertrauensstellungen” – Eigenschaften der aktiven Domäne in den “einheitlichen Modus” versetzen (war vorher im gemischten NT4/Win2k-Modus).
  • Dann wiederum am Server 2000 von der Server 2008-CD den Befehl adprep32 /domainprep ausführen
  • Am Server 2008 dcpromo.exe ausführen und den Server als zusätzlichen Domänen-Controller im Netz installieren, es wird auch der DNS-Server installiert und konfiguriert.

Jetzt war dann erst mal Pause – diese Infoseite hat mir dann aber beim Heraufstufen des 2008er-Servers zum Haup-Domänencontroller sehr weitergeholfen: https://technikblog.rachfahl.de/losungen/umzug-einer-active-directory-domne-von-einem-small-business-server-2003-zu-einem-windows-server-2012/

Folgende Kommandos (jeweils am neuen Server 2008 durchzuführen) sind für die Übertragung der FSMO-Rollen verantwortlich (sprich, aus dem Backup Domaincontroller wird der Primäre Domaincontroller. Ich zitiere die o.a. Website):

Administrative Eingabeaufforderung öffnen, folgende Befehle eingeben:

  • NTDSUTIL
  • Roles
  • Connections
  • Connect To Server <Servername_des_neuen_Servers>
  • Quit

Jetzt die Übertragung der Rolen starten, Popup-Fenster jeweils mit “Ja” bestätigen:

  • Transfer Schema Master
  • Transfer Naming master
  • Transfer RID Master
  • Transfer PDC
  • Transfer Infrastructure Master

Danach zweimal QUIT eingeben – fertig.

Anmerkung (habe ich noch nicht kontrolliert): Wenn Sie einem SBS-Server die Rollen wegnehmen, empfindet dieser das als “Verstoß gegen seine Betriebsregeln” und startet nach einer gewissen Zeit in regelmäßigen Abständen neu. Standardmäßig liegt dieser Zeitraum bei 7 Tagen, der Patch KB943494 verlängert diesen Zeitraum auf 21 Tage.

Als nächstes habe ich versucht, nun in der Domäne, in der sowohl ein alter Windows 2000 Server mit Exchange 5.5 und SQL 2000 läuft, mit Windows XP und Windows 10 zu experimentieren, um festzustellen, ob alles nach wie vor funktioniert (würde mir eine Verschnaufpause für die Echt-Umstellung verschaffen). Am XP-Client scheint alles klaglos zu funktionieren, der Windows 10 Client kann sich jetzt auch an der “alten” Domäne anmelden, was allerdings NICHT funktioniert ist zB Outlook 2010 – das verweigert die Zusammenarbeit mit dem alten Exchange 5.5-Server. Aber auch hier hilft es zwischenzeitlich, Outlook 2003 unter Windows 10 zu installieren – das klappt einwandfrei, auch die Verbindung zum alten Exchange-Server!

 

Shutdown eines ESXi-Servers mittels einer APC-USV und einem Windows-Host

Lange habe ich gegrübelt, wie man wohl ohne aufwendiges “Gepfriemel” einen ESXi-Host (von VMware) bei einem Stromausfall, der länger dauert, korrekt herunterfahren könnte. Im Netz bzw. auf den VMware-Supportseiten findet man dazu alle möglichen Hinweise – von der Installation eines eigenen Plugins in den ESXi-Host (very complicated) bis hin zur Verwendung einer speziellen (und nicht gerade günstigen) Netzwerk-Verwaltungsschnittstellenkarte von APC selbst. Dabei ist die Lösung so einfach:

Man schleift die USB-Schnittstelle des ESXi-Hostservers, an der die USV angeschlossen ist, zu irgendeiner virtuellen Windows-Maschine (die auf ebendiesem ESXi-Host läuft) durch (Hardware konfigurieren, hinzufügen: USB-Controller, OK, Hardware hinufügen: USB-Gerät, die USV auswählen, OK) und installiert auf dieser virtuellen Windows-Maschine die kostenlose Powerchute-Version von APC (die jeder USV beiliegt bzw. von der APC-Homepage heruntergeladen werden kann).
Zur Sicherheit habe ich dem “APC PBE Agent”-Dienst noch ein lokales Administrator-Konto zugewiesen, damit er ungehindert agieren kann.

Danach wird´s ein bisschen komplizierter – allerdings nicht sehr:
Die SSH-Schnittstelle am ESXi-Host freischalten (Konfiguration vom ESXi-Host, Software, Sicherheitsprofil: Eigenschaften, dann den SSH-Dienst auswählen, Optionen, entweder auf “automatisch starten…” oder “mit Host starten”) und danach natürlich auch starten.

Dann in der Windows-Client-Maschine das Programm “putty” sowie “plink.exe” (http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html) z.B. in den Ordner c:\putty herunterladen und (zumindestens) einmal eine SSH-Verbindung + Login zum ESXi-Host aufbauen (SSH-Key wird automatisch installiert), diese Verbindung in Putty speichern und den dabei vergebenen NAMEN merken.

Jetzt im CMDFILES-Ordner der APC Powerchute-Installation (üblicherweise c:\program files (x86)\APC\Power Chute Business Edition\agent\cmdfiles) eine eigene CMD-Datei anlegen (zB shutserver.cmd), die folgenden Befehl enthält:

@START “” “c:\putty\plink.exe” ESXI -l USERNAME -pw PASSWORT “/sbin/shutdown.sh && /sbin/poweroff”

ESXI = der Name der Verbindungssession, die in Putty gespeichert wurde
USERNAME / PASSWORT = Username und Password des Root-Accounts des ESXi-Hosts

Jetzt bleiben nur mehr zwei Tasks bis zum erfolgreichen Shutdown: In der Powerchute-Konfiguration die soeben angelegte “shutserver.cmd”-Datei im Menu “Shutdown” unter “Shutdown settings” (no na 😉 anwählen und (falls nicht sowieso bereits geschehen) am ESXi-Host die entsprechenden Aktionen zum Herunterfahren der virtuellen Maschinen konfigurieren (ESXi-Konfiguration, VM starten/herunterfahren, Eigenschaften) – also entweder “Herunterfahren” oder “Anhalten”.

Ich habe das Script getestet, es hat einwandfrei geklappt – ein vorheriger Wechsel des ESXi-Hosts in den Wartungsmodus war nicht nötig.

Hier der Vollständigkeit halber (mit Dank) noch der Link zu dem Originalartikel, der mich auf die richtige Spur gebracht hat:

https://community.spiceworks.com/how_to/55064-how-to-gracefully-shut-down-vsphere-5-x-esxi-free-using-an-eaton-ups-with-ipm-and-the-command-line

Den zweiten wichtigen Artikel, in dem ich darüber aufgeklärt wurde, dass man die Variablen für das @START-Kommando des APC Powerchute-Scripts (also zB @START “” “c:\putty\plink.exe” variable1 variable2 etc.) außerhalb der Anführungszeichen plazieren muß, werde ich nachreichen (wenn ich ihn wiedergefunden habe).

Ein weiterer interessanter Artikel, der sich mit dieser Thematik beschäftigt: https://www.binarus.de/articles/apc-usv-network/apc-usv-network.shtml

Neues Lieblingsmesser: CRKT Ikoma “Fossil” (Plain Blade Folder)

Unlängst stolperte ich beim Surfen auf der Böker-Homepage über ein Messer in sehr interessantem Look – das “Fossil” vom Designer Flavio Ikoma, gefertigt von CRKT (Columbia River Knife and Tool). Neugierig geworden bestellte ich es mir gleich beim “grossen Versandhaus” und wenige Tage später hielt ich das wild aussehende Teil in der Hand. Mittlerweile (und nachdem ich der Klinge einen neuen, feineren Schliff verpasst habe) gefällt es mir immer besser, es liegt extrem gut in der Hand und hat genau die richtige Größe für viele Aufgaben. Einziges Manko: Steckt es mit dem Clip gesichert in der Hosentasche ist es recht unangenehm, die Hand einzustecken – die Oberfläche des Griffmaterials ist doch recht rau.

CRKT Ikoma "Fossil"

Alten Diascanner wiederbeleben – CanoScan FS-4000US unter Windows 10

Ungefähr Anfang 2003 habe ich mir einen echten Diascanner gekauft – den CANON FS-4000US, mit USB (v1.1) und SCSI-Anschlüssen. Damals war eine SCSI-Karte im PC noch weitverbreitet, der Anschluss darüber klappte gut und die Geschwindigkeit war besser als via USB. Um das Scan-Ergebnis zu verbessern kaufte ich dann auch noch die professionelle Silverfast-Scansoftware Ai 6 inkl. der IT-8 Kalibrierungs-Target dazu – alles in allem ein recht umfangreiches Gesamtpaket zu einem nicht unerheblichen Preis. Nachteil des Scanners von Anfang an: Er ist recht langsam, und wenn man die hardwaremässige Infarot-Stauberkennung nutzt, doppelt so langsam (die funktioniert zudem bei schwarzweiss-Negativfilmen aufgrund des Silbergehalts nicht bzw. nahezu nicht).
HIER wird der Scanner ausführlicher vorgestellt.

Einige Jahre später (2008) kaufte ich mir dann den EPSON V750PRO Flachbettscanner mit Durchlicht- und Nass-Scaneinheit – vor allem in Beziehung auf die Geschwindigkeit und natürlich Scangrösse ein Quantensprung. Mit der grossen Durchlichteinheit konnte ich auch problemlos Mittelformat- (bzw. 6×7 cm) und Grossformat (4×5″)-Filme einscannen. Die Investition in die Nass-Scan-Platte inkl. entsprechender Flüssigkeiten und Klebebändern entpuppte sich allerdings als Schuss in den Ofen, denn es ist nunmal sehr schwer, Negative oder Dias auf einer planen Oberfläche blasenfrei zu befestigen – nicht umsonst sind die absoluten Spitzenklassenscanner Trommelscanner (oder der Film wird, wie beim Hasselblad Flextight, durch eine patentierte, glaslose Führung gekrümmt).

Die Qualität des Epson überzeugte mich weitestgehend, alleine die Schärfe (speziell beim Scannen von Kleinbildfilmen) liess immer zu wünschen übrig – der Canon-Scanner zeigte auch das Filmkorn, das war beim Epson quasi nicht möglich.

So entschied ich mich nach Jahren, in denen der Canon im Regal beinahe verstaubte, diesen wieder in Betrieb zu nehmen und mich bei einem direkten Vergleich zu überzeugen. Problem: Mein PC läuft inzwischen unter Windows 10/64bit, die letzte Treiberversionen für den Canon FS4000-US datieren aus dem Jahre 2003 und es gibt überhaupt nur einen Treiber für Vista (ein schrecklicher Ausrutscher von M$, übrigens – ähnlich wie Windows ME) und der nur für 32 Bit. Was also tun?

Ich entschied mich für eine VMware-XP-Box, die auch hurtig aufgesetzt war, und sobald das System lief, versuchte ich auch den am USB-Port korrekt erkannten Canon-Scanner an die VMWare-Maschine “anzuhängen” – klappte auch zuerst, allerdings erkannte das (neu aufgesetzte!) Windows XP den Scanner in der virtuellen Maschine nicht. Nach kurzer Zeit gab es sogar eine VMWare-Fehlermeldung und der Scanner “verschwand” wieder aus der virtuellen Maschine.

Intensive Recherche im Netz förderte einige Minuten (also, eigentlich viele) später einen Lösungsvorschlag zutage: VMWare komplett deinstallieren, neu installieren, nochmal probieren. Etwas skeptisch versuchte ich es damit, und siehe da – plötzlich wurde der an die virtuelle Maschine übertragene Scanner korrekt erkannt und ich konnte auch den (alten) Treiber korrekt installieren. Jetzt noch flott die Silverfast-Software drauf und eine alte Photoshop-Version hinzufügen, fertig ist die “Rettungsinsel” für den Canon FS-4000US!

Nach einigen Testscans kann ich sagen, dass das ganze System recht stabil läuft – die gescannten Dateien kann ich via “Shared Folders” oder Netzwerk an den HOST übertragen und dort mit modernsten Mitteln nachbearbeiten. Aus Geschwindigkeitsgründen ist die virtuelle XP-Maschine natürlich auf einer SSD-installiert – alles in allem belegt sie dort ca. 14 GB.

Welches der beiden Scan-Ergebnisse mir nun besser gefällt kann ich noch nicht sagen – ich habe versucht, mit beiden Systemen (sowohl Epson als auch Canon werden von Silverfast Ai mit entsprechenden “NegaFix”-Einstellungen, welche die Eigenheiten nahezu aller erhältlicher Negativ-Filme korrigieren können, angesteuert) unter etwa gleichen Bedingungen zu scannen, ein Vergleich ist hier möglich (links der Canon, rechts der Epson):

Scanergebnis-Vergleich Epson-Canon

Links zu den Fotos in Originalgrösse: CANON / EPSON

Ein paar Beispiele von der letzten Scan-Session:

pimp my iPod (4th generation/photo)

ipod-display

Angeregt durch einen online-Artikel, der das relativ leicht funktionierende Upgrade eines iPods der 4. Generation (“Photo”) mit einer Flashdisk beschreibt, holte ich mein seit Jahren in der Schublade schlummerndes Exemplar wieder einmal an´s Tageslicht und beschloss, diesen Umbau ebenfalls vorzunehmen. Die dafür notwendigen Teile sind leicht zu besorgen – beide Adapter für den Ersatz der mechanischen Festplatte mit CD oder SD-Karte sind über Händler bei Amazon erhältlich. Da eine CF-Karte in der mir vorschwebenden Grösse von 128 GB noch relativ teuer ist, bestellte ich nicht nur den iPod-Adapter http://www.amazon.de/gp/product/B0020D5MHG (8,45 Euro), sondern auch den SD-auf-CF-Adapter: www.amazon.de/gp/product/B004QY0M7C (15 Euro)
(Anm: Der SD-CF-Adapter ist zwar mit “High Speed” bezeichnet, verringert allerdings die Schreib-/Lesegeschwindigkeit meiner 128 GB  SD-Karte um mehr als die Hälfte…traurig! Dafür ist er billig 😉

Zum Öffnen des Gehäuses verwendete ich Werkzeug aus dem iFixit-Toolkit, welches sowieso in keiner Bastelwerkstätte fehlen darf: https://eustore.ifixit.com/Werkzeuge/Toolkits/Pro-Tech-Toolkit.html

Eine Anleitung zum Öffnen des Gehäuses findet sich ebenfalls auf der iFixit-Seite (bei dieser Gelegenheit kann man auch gleich den Akku erneuern, wenn man will…ebenfalls auf der iFixit-Seite zu finden 😉
https://de.ifixit.com/Guide/iPod+4th+Generation+or+Photo+Battery+Replacement/393
(Anm: Nicht die Geduld verlieren, das Öffnen ist ein wenig tricky…)

Der Respekt vor dem in manchen Blogs geschilderten Problem am Ende des Restore-Vorgangs der iPod-Software, der ein Anschliessen des an das “Original-Ladegerät” fordert, war unbegründet – das etwas klobigere iPod/iPhone-USB-Ladegerät war anscheinend vollkommen ausreichend.

Nach ca. 30 Minuten war die ganze Aktion erfolgreich beendet – ein paar Fotos von dem nunmehr um einige (!) Deka leichteren iPod “Generation 2016”, der zudem nun auch ziemlich stoßfest ist, gibt es hier:

der geöffnete iPod 4th Generation "photo"

60 GB - original-Festplattengrösse

Nach dem Umbau: Volle 119 GB verfügbar!